SOME-LIBS(7) Miscellaneous Information Manual SOME-LIBS(7) NAME Some Libraries – good ones DESCRIPTION This is a little list of C libraries I've had good experiences using. -lcurl The library behind the curl(1) command. It downloads or uploads things on the internet through a number of protocols, not just HTTP. It has an easy-to-use library API, appropriately named libcurl-easy(3). I've used it to implement a page title fetcher: https://causal.agency/bin/title.html. -lcurses Okay so this one really isn't great. Its interfaces can seem archaic and its documentation is often poor. However, it gets the job done and is commonly available pretty much everywhere. Interesting to note that NetBSD uses its own implementation of curses that is not GNU ncurses, unlike FreeBSD. -ledit This is a BSD line editing library, similar to GNU readline. It supports right-aligned prompts, which I prefer for variable- length information in shells. -lkcgi A CGI and FastCGI library for web applications in C. Don't worry, it isolates HTTP parsing and input validation from application logic in sandboxed processes. I think it's an excellent example of how to design an API for C. I used it to implement the torus web viewer: https://ascii.town/explore.html. -lsqlite3 An embedded relational database engine. It's amazing what you can do with this, and it's super easy to use! My one gripe with it is that the library and SQL documentation are not available as man(1) pages. I'm currently working on a project using SQLite, but it hasn't gotten very far yet. -ltls This is a new library in LibreSSL which provides a much simpler interface for TLS sockets compared to -lssl. It's much more like what you'd expect from other TLS socket wrappers, with calls like tls_connect(3), tls_read(3) and tls_write(3). I've used this for IRC clients, bouncers and bots. -lz An implementation of the DEFLATE compression algorithm and gzip format. It's all documented in comments in , which isn't bad, but for my own use I copied the docs into manual pages: https://code.causal.agency/june/zlib-man-pages. I've used this for decoding and encoding PNG images. AUTHORS June Bug Causal Agency December 11, 2019 Causal Agency